Author Topic: plot won't advance after crash & load  (Read 196 times)

click

  • Hopeless
  • *
  • Posts: 1
plot won't advance after crash & load
« on: October 17, 2017, 10:57:23 PM »
I was playing my first playthrough (ironman) over the weekend.  I had just experienced the event (near the end of the game?) where 4 new green locations appeared on the map (Atlas and 3 others with the same name which started with E) and I had to race some chruul to these things to fetch artifacts.

I sent my main fleet to the northeast location and a fleet of 2 of the freshly gifted alien ships plus a human to the northwest location.  When they were perhaps half way to their destinations, I decided it might be a good idea to level up the aliens before any fighting commenced.

When leveling up one of the aliens, which was not of the tactical class, I noticed that the icons for the prestige tree looked like the commando icons (same color and paw print).  I thought this was strange so I clicked one of them.  At this point the game started to draw its window even more incorrectly (glitches, various rectangles on top of things) so I right clicked to get out of the level up interface.  This caused the game to crash.

Today I tried to continue my game.  It seems to be in a strange state.  The chruul that were attacking halcyon and heading to the precursor locations are all gone.  The 4 locations are also gone.  There are no missions available.  I can move the halcyon 6 fleet "h6" anywhere on the map and destroy anything in a single turn.  Is there something I can do to force the plot to advance?  Is there a way I can trigger the attack on halcyon 6 and the appearance of the 4 locations with the precursor artifacts?

MongooseCalledFred

  • Global Moderator
  • Sentinel
  • *****
  • Posts: 320
  • I think, therefore I'm slow.
    • Guide to Beating the Chimera
Re: plot won't advance after crash & load
« Reply #1 on: October 18, 2017, 11:38:40 AM »
Was the alien with the Commando prestige class an Engineer->Mechanic? That's normal. I have no idea why it crashed. However, I can help with getting the game going again. In the Gameplay section of the Options menu, enable Dev Mode. Back in the game, press the ` key. (Right below escape.) Type

ActivateQuest("act3_framework")

into the console that pops down. Press enter, then escape. You should now have the graveyards and mothership again. (You might want to disable Dev Mode now.) If this doesn't work for you, I'll keep looking. :)
Celebrate with me! I finally hit Sentinel!

MongooseCalledFred

  • Global Moderator
  • Sentinel
  • *****
  • Posts: 320
  • I think, therefore I'm slow.
    • Guide to Beating the Chimera
Re: plot won't advance after crash & load
« Reply #2 on: October 20, 2017, 11:40:40 AM »
Did it work? I only tried it on a new file.
Celebrate with me! I finally hit Sentinel!